Announcement

Collapse
No announcement yet.

Mount Bug

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mount Bug

    my emerald spider expired and i can't ride any other mount refreshed a lot of times chosen all the mounts i have and nothing.

    Click image for larger version

Name:	shadowbound 1.png
Views:	1
Size:	713.3 KB
ID:	1760281

    Server: 5
    in-game name: psi

  • #2
    click another mount. click glamour
    Now Playing ~ Shadowbound [S13] - Hunter

    played games so far (in many different account) ~ Crystal Saga, Wartune, Broken Realm, Eternal Saga, Dragon Pals, Yitien, Blade Hunter (alpha), Lunaria Story, League of Angels, Monkey King Online, Crusader of Solaris, Shadowbound, Mythborne (alpha), Stormthrone (alpha) more list to come

    Comment


    • #3
      ^ If you look in the screenshot he did choose another mount and clicked glamour, but still no mount.
      Shadowbound
      [S19] Bahold Castle - Solaria Luna - Warrior - Lv75
      [S75] Secret Sanctum - Hunter - Lv38
      League of Angels
      [s147/ua25] Thane of Winter Sorceror - Lv79
      ___________
      Eternal Saga - Ranger - Retired
      Lunaria Story - Elementalist - Pretty much retired

      That being said character names in games I play is Solariai

      Comment


      • #4
        as i said i tried all mounts with glamour and nothing

        Comment


        • #5
          Originally posted by papas View Post
          as i said i tried all mounts with glamour and nothing
          I would suggest these steps.

          1. Close game
          2. Empty cache and cookies from r2games
          3. Refresh whole browser
          4. Restart game
          5. Try mount again

          Won't fix all in 100% of cases, but it can surely help.
          Tigerstorm, s1 Nova Genesis
          Tigerstorm, alpha WinterFury
          --- Many retired chars in most r2games games.

          Comment


          • #6
            Go to the mount training tab and ride your mount again.

            Comment


            • #7
              thank's a lot i forgot to do that i appreciate all the help

              Comment

              Working...
              X