Announcement

Collapse
No announcement yet.

Socket not showing in forge menu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • R2120242705
    started a topic Socket not showing in forge menu

    Socket not showing in forge menu

    Hi All. Have a strange issue that even has the VET help in game scratching their heads. I am a lvl 39 warrior on White Thorn Server. I have a few other characters on other servers higher level than 35, which is the level for gems to be available, so I know that it can be used. For some reason, the socket option is not coming up when I click on the forge icon. All I have are Enhance, Upgrade, and Gem Upgrade. I have a full set of blackwind gear. When I hover over the blade and armour it says can socket.
    I have heaps of gems but when I click on them, and select socket, a red Unactivated flashes up on the screen. I am at a complete loss as to why this is happening. I have looked through the forums and cant find anything that matches this problem. I have spent a bit of money on this game, and I don't want to lose this character, but I cant really play it if I cant socket gems.
    I saw one post that said I may have to compete a quest to activate the sockets. Anyone know what that might be, and have I missed it??
    Thanks in advance.

  • Aotearoa
    replied
    The quests pop up as Main quests. The one for Gems also unlocks your Craft.

    Leave a comment:


  • Kitwritten
    replied
    we need your character and server name please

    Leave a comment:


  • xXDminXx
    replied
    Have you done all the main quests listed in the quest tracker?

    Leave a comment:

Working...
X