Announcement

Collapse
No announcement yet.

Quest Help Carter(Weapons Vendor)

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quest Help Carter(Weapons Vendor)

    I have a quest from carter(Weapons Vendor) in Aurora Point and he gave me a quest socketing optional and i have done. It say the use the weapon vendors equipment to learn how to socket equipment. (Click on "Socket" in your inventory to open the socket panel.) Under that i have done the ( Socketing Rod Bound). Then it say to do the (Chipped Jade Gem (Bound) and the Socketing Rod is gone it say to use it again so i went and got another one and it didnt even work still and it wont even go into the slots when it still say the rod is there a guild of this some where i got this yesterday and still wont work ???

  • #2
    Here are the steps to socket an item:
    1. Click on Socket in your inventory
    2. Drag item into the top box, under Equipment
    3. Make sure you have socketing rods in you inventory, and click on the first crossed out square in the second row. Cllck 'Add Socket' at the bottom.
    4. Drag gem into the square that is now not crossed out. Click Yes on the window that pops up.

    Which step are you getting stuck on?
    Interested in becoming a Forum Moderator? Fill out the application HERE!

    Rules of the Forum are found here.

    R2Games Ticket System for browser games: www.r2games.com/support
    Mobile game Ticket System is accessed through the in-app support link.

    For additional assistance with a ticket, please provide a moderator with your ingame name, server, and game.

    Comment


    • #3
      I put the Test socket Token + 1 into the Equipment slot with the gem under it shows when i click the gem then the remove gem it say into the slot at the bottom of it? I have the check off the socketing rod bound aim on the other part of the quest where it say Chipped Jade Gem Bound and when i click the inventory it has a arrow pointing to the socket saying left click? and again the box comes up like the first one i done with the check mark on it then what on the seconded part nothing work?

      Comment

      Working...
      X