Official Community Discord Server

Join us on the new R2Games Community Discord Server!
See more
See less

S83 Login Failed

  • Filter
  • Time
  • Show
Clear All
new posts

  • S83 Login Failed

    Still can't connect to [S83] Crystal Sanctuary

    I have tried all of the following (and more)
    ~ Clearing your browser history, cache, and temporary files
    ~ Refreshing your browser session
    ~ Using different browsers (used 3 different already installed and downloaded a fresh new browser and still didn't work)
    ~ Restarting your device/Internet source
    ~ Using wired connection instead of wifi (and used 2 different computers)
    ~ Using a proxy
    ~ Manually changing your DNS/IP address

    Tried multiple DNS:

    Checked R2 Crystal Saga General Support Thread:

    Even sent a support ticket im still waiting on. Continue to get error message: "Login Failed: Failed to connect to server!"

  • #2
    I have tested S83 and did not encounter any login errors, as shown below with the server timestamp. There also appears to be other players online. As this is currently the only report, it may be an isolated issue. If you would provide your ticket number, a moderator will forward it for you when available to. Since it is the weekend, there will be a delay in response times.


    • #3
      try to log-out and login several times maybe, cuz if you're using a server bookmark your browser might be logging you out from r2 when you close it or restarting your comp

      im usially getting 'please login first' screen redirecting me to the main site to login

      that's what im getting or 'authorisation error' not letting me to get on

      restarting my connection/browser/cs tab usially fixes it

      and im playing s83 too never got an issue with it yet

      check your browser, connection, and login through the main site