Announcement

Collapse

Official Community Discord Server

Join us on the new R2Games Community Discord Server! https://discord.gg/VFMzFDqKq5
See more
See less

I've been robbed

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • rolyat
    started a topic I've been robbed

    I've been robbed

    On March 19, 2013 I purchased crystals for $4.99 and expected to see not only crystals but an assortment of goodies appear magically in my pack in Crystal Saga. NOTHING has shown up but a credit card charge. I tried to do a ticket, apparently that is beyond my capability. I tried to log in to my account where I paid for the stuff I missed on the first attempt and my account got locked. This was a test. I will not spend any more time or money. This is just a vent. I really don't expect any thing to come of it. Once a thief has your money you've lost. I am on Empyrean Acropolis [S61], my character is homer. That last just in case there is an honest person somewhere in your organization with the power and inclination to help.

  • MemoryLane
    replied
    Can you explain the issue you are having with sending in a ticket? You probably have a very easy to resolve issue, but they need a ticket sent in so they can check on it for you.

    Most common issues for not being able to send in a ticket are the account name is wrong (yours is "rolyat") or the attachment wasn't the proper size or format (copy/paste the payment info into the ticket instead of attaching a screenshot if needed). As for the transaction number, just put anything in that box (I use 11111111 myself).

    If you still need help with the ticket, I will send you a screenshot for you to copy.

    Leave a comment:

Working...
X