Announcement

Collapse
1 of 2 < >

Forum PMs and Mail

Due to an error in the current version of vBulletin, most are experiencing errors with the private messaging system. Please do not send moderators private messages for assistance at this time. If you have an issue that requires privacy, let us know in your new post or thread and we will work with you to find another option. Thanks - The Moderation Team.
2 of 2 < >

R2 LOGIN ISSUES

For recent R2 login issues, please log in through the website starting with "https": https://www.r2games.com. In addition, the bookmark of the saved URL may still contain the word "http", please change it to "https". If this does not work for you, please clear the cache and cookies to complete the most recent update, or try again with another browser. Thank you.
See more
See less

Bug Report Mega-Thread: Dragon Pals

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • R2_Sanguine
    started a topic Bug Report Mega-Thread: Dragon Pals

    Bug Report Mega-Thread: Dragon Pals

    Click image for larger version

Name:	Bug-Reports-Forum-Guidelines.png
Views:	15
Size:	129.3 KB
ID:	1772933

    In this thread, we will collect information for any bug or game issue in Dragon Pals. Please read this post in its entirety and check if your issue has already been reported before posting. Our goal is to facilitate bug reports effectively and understanding how to use this thread will help expedite issue reports.

    The purpose of this thread

    The purpose of this thread is to provide one place for reported and confirmed bugs as well as supporting information. This thread will include one example of each bug or glitch, along with documentation, a clear description, and other various supporting information. This will enable all of our players to know that a bug has been reported and acknowledged.

    Players are asked to open a supporting thread (or link an existing one if it exists) to give players a place to expand on the original report and provide additional information. If someone has submitted your issue successfully, please visit the accompanying link and post your information there.

    How to submit an issue on this thread

    When reporting a bug, there are a few pieces of information that are completely necessary. Also, please report only one bug per post. If you need to report more than one bug, report each bug in a separate post. *Please note* Your request will be deleted if it does not include ALL of the following information:

    -A screenshot clearly displaying the issue: The nature of most bugs require a screenshot or video. We realize that getting a screenshot or video after the fact is impossible, so we want to get all of our players in the habit to hit that “screen capture” button if they notice something out of the ordinary. If you require a tutorial on an easy-to-use Screenshot program, you can visit our guide here: r2gam.es/1wkyT48 You can find a tutorial on a video capture program here: r2gam.es/1KlOF3d

    -Character information: We need to check your character data, and this should be included with your preliminary report. Please include your character name, server, server timezone, and platform (Kabam, R2, Kongregate, Armor, etc).

    -A clear description of the problem: What server date and time did this happen? What game function is this in? What steps do we need to take to reproduce this bug? Did you notice anything else out of the ordinary? (These are just some of the questions that help paint a full picture of a bug report.

    -Bug Classification: For a full detailing of how to classify a bug, you can visit our guide here - r2gam.es/1B0M5ye. Most bugs fall under “functional”, “graphical”, or “language”. Is the issue with a specific game function, does it interfere with game/UI graphics, or is there Chinese/language bleeding into each other?

    -A link to a supporting thread for this issue: whether you need to create a thread or someone already has, we want to give players (and us!) a place to talk about bugs more at length and provide additional evidence to support a report. If a thread about this issue exists, please include it. If not, we either encourage you to make a separate thread for this purpose or have our Moderators add the link after your submission has been posted.

    Some things to remember

    This is a place for bug reporting and collection, so please only include necessary information in your report. Please refrain from expressing your frustrations, requesting updates, slander, or anything not specific to reporting a bug. We want to do our best at fixing all issues, and this means handling issues of high priority first. We always prioritize game-breaking issues as first to fix, and then lower priorities as the problem becomes less severe; fixes of low priority issues will be slower than an issue that “breaks the game”.

    We can rarely provide a timeline for a fix or compensation. We always want to fix issues sooner rather than later, but timelines may come down to “we’re working on it”. We need to confirm and identify a bug, suggest a potential fix, and then wait for a fix to be implemented. We will not give timelines for fixes or compensation until a fix has been made or compensation has been decided, and will be announced through official game channels.

    Any updates from R2 staff, Mentors/Vets, GMs, or Moderators will be done so on the supporting thread and may be sporadic. Please be patient with all GMs or Moderators as we are typically dealing with multiple issues simultaneously. We pass on information from other parties to our players, so everything we know, you know. If you don’t get an update after a few days, poke one of us for an update!

  • R234775198
    replied
    Problem solved. Thank you.

    Leave a comment:


  • R234775198
    replied
    Hi I am having an issue with upgrading a guild. It says guild is level 1. The shop, technology, warehouse, and battle fort are all level 1. When I try to click the upgrade now button ( timer is 0) next to guild level button It does nothing. How can I upgrade guild? I am the guildmaster.
    Last edited by R234775198; 11-29-2017, 03:06 PM. Reason: Missing information.

    Leave a comment:


  • hellabella_S1
    replied
    CoolShop in CoolIcecream event not working

    Screenshot displaying the issue:
    Click image for larger version

Name:	cool shop.png
Views:	2
Size:	699.9 KB
ID:	1726390

    Character information:
    hellabella, S4 Westhollow, EU but problem also on the S9, S45, S98 Europe (at least for the chars I have).

    Clear description of problem:
    Discovered on 23rd August, on S4, S9, S45 and S98 Europe, around 1pm GMT.
    In Cool Icecream event, Cool Shop is not displaying items so that to be exchanged for cool points gathered after using icecreams. In Online bonus also, though you get the Summoning horns, what is displayed there are amethysts.

    Bug classification:
    I do not know for sure but I'd say it is both functional and graphical.

    Link to a supporting thread for the issue:
    http://forum.r2games.com/showthread....-on-cool-shop-!
    Last edited by hellabella_S1; 08-25-2016, 11:52 PM.

    Leave a comment:


  • Alkaris
    replied
    Level 1 stones add 6000 of the respective trait, level 2 stones add 8000 to
    the respective trait, but level 3 stones drop to 1500.
    Except crit and crit def, they are different.
    But lvl3 is a bug and it is reported.

    Leave a comment:


  • R269785101
    replied
    When you smelt a level 3 star soul stone, you lose battle rating. Level 1 stones add 6000 of the respective trait, level 2 stones add 8000 to
    the respective trait, but level 3 stones drop to 1500.

    http://prnt.sc/b7q7i7

    RagnaRick
    Server 134 Goblin's Gully US East

    This is clearly a functional and typographical bug.

    Leave a comment:


  • Alkaris
    replied
    All, from US East, who lost support passes due to a merge you need to open ticket at http://www.r2games.com/support/
    Any other posts in this thread about this issue will be deleted.

    Leave a comment:


  • lasherfnm
    replied
    They have give me the 2 Supports Tickets missed.. TYVM!

    CSC, can't claim rewards for support and cant's claim for qualifier (my team reach top 16) nor redeem rewards. My team name is AMIAM.

    I have seen my team had gone too...

    In the print screen of the support says "supported no opp" that's not right, i was supported the team Weaklinks or something like that...

    Click image for larger version

Name:	Dibujo.JPG
Views:	1
Size:	196.5 KB
ID:	1724939Click image for larger version

Name:	Dibujo2.JPG
Views:	1
Size:	216.8 KB
ID:	1724940Click image for larger version

Name:	Dibujo3.JPG
Views:	1
Size:	233.7 KB
ID:	1724941
    Last edited by lasherfnm; 05-25-2016, 06:51 AM.

    Leave a comment:


  • shadowsbreath1
    replied





    and i got that same message today with help so its not a solo thing


    AbbyBacon

    S6 emerald isle

    Leave a comment:


  • shadowsbreath1
    replied


    i get that message after each MP when i solo them since yesterday and cant collect anything at all , do i need help with the MP now to collect that reward?

    AbbyBacon S6

    emerald isle
    Last edited by shadowsbreath1; 04-30-2016, 07:26 AM.

    Leave a comment:


  • dasha.taillefer
    replied
    Click image for larger version

Name:	Capture d’écran (202).png
Views:	1
Size:	787.2 KB
ID:	1724110

    Character name : _Arwen
    Server: [S173] Dusky Island
    Server Timezone: US East
    Platform: R2

    Time: after 12:00 am EST on March 22nd

    Problem: every time I try to do a fight in Solo Showdown, I get the "Matching Opponents" message, but no opponents are found. The countdown goes to 1, then the message dissapears and no fight is loaded. Other people on the server have the same problem.

    The solo showdown bug from post #18 is back since April 11th on S173 Dusky Island.
    Last edited by Alkaris; 04-14-2016, 01:54 AM.

    Leave a comment:


  • hellabella_S1
    replied
    Tribal Clash not working again

    char IGN: hellabella
    S4 Westhollow, EU
    Date and time: Sunday, 20th of March, 9:10 pm (7:10 pm server time)
    TC started, we could enter it but couldn't pick any track for fight, as you'll see in the SS below. After TC ended we got "claim your reward" message though neither of the servers could participate.

    Click image for larger version

Name:	TC bugged.png
Views:	1
Size:	575.8 KB
ID:	1724093 Click image for larger version

Name:	TC bugged 1.png
Views:	1
Size:	678.0 KB
ID:	1724094

    Same issue on the opponent server, with the same message received.


    RESOLVED
    Last edited by Alkaris; 04-14-2016, 01:53 AM.

    Leave a comment:


  • Fairulia
    replied
    -A screenshot clearly displaying the issue:
    http://prntscr.com/aa6x1w

    -Character information:
    Character Name: Takani
    Server: [S76] Whispering Woods
    Server Timezone: Europe
    Platform: R2

    -Character information:
    Character Name: Taka
    Server: [S165] Muscat Highlands
    Server Timezone: Europe
    Platform: R2

    -Character information:
    Character Name: TakTak
    Server: [S163] Razorcliffs
    Server Timezone: Oceanic
    Platform: R2

    -A clear description of the problem:

    What server date and time did this happen?
    Except the server 165 that had never before happy fight with real enemy,
    the other 2 servers after the last merging on 10/14 @ 2:00-4:00 EDT, they lost it.
    What game function is this in?
    Happy Fight


    -Bug Classification:
    Us East and Us West don't have that situation, appear only in Europe and Oceanic

    -A link to a supporting thread for this issue:
    http://forum.r2games.com/showthread....-real-opponent

    Leave a comment:


  • cfritters18
    replied
    Character Information : Cornicopia, s166 Centaur Fen, (US West)

    Problem: Cannot collect Hot Event wardrobe boost after upgrading wardrobe. Message appears stating clear inventory even though I have 9 slots open.
    Click image for larger version

Name:	Inventory.png
Views:	1
Size:	171.5 KB
ID:	1723024Click image for larger version

Name:	DP collect.png
Views:	1
Size:	250.6 KB
ID:	1723025

    Classification: Functional bug

    Ah bugger - TY thought it was 1000 not 10000

    RESOLVED
    Last edited by Alkaris; 01-13-2016, 06:54 AM.

    Leave a comment:


  • R269008869
    replied
    i try clicking on the "Baby Cow Issue" but nothing happens, so i'll type it. I think its fixed now? Baby cow is on the last/2nd to last page.

    RESOLVED
    Last edited by Alkaris; 11-17-2015, 03:41 AM.

    Leave a comment:

Working...
X