Announcement

Collapse
1 of 2 < >

Forum PMs and Mail

Due to an error in the current version of vBulletin, most are experiencing errors with the private messaging system. Please do not send moderators private messages for assistance at this time. If you have an issue that requires privacy, let us know in your new post or thread and we will work with you to find another option. Thanks - The Moderation Team.
2 of 2 < >

R2 LOGIN ISSUES

For recent R2 login issues, please log in through the website starting with "https": https://www.r2games.com. In addition, the bookmark of the saved URL may still contain the word "http", please change it to "https". If this does not work for you, please clear the cache and cookies to complete the most recent update, or try again with another browser. Thank you.
See more
See less

Have problems getting magic lamp to work?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Have problems getting magic lamp to work?

    For the longest time I didn't understand why, with my account being linked to FB even, I couldn't get magic lamp to share to receive my magic cloth.

    Turns out the problem was that my Adblock was turned on for this site. After turning it off, I was able to then share and claim the rewards. However, you can only claim them each once with the exception of the "Share your gaming experience."

    You should be logged into your FB account, I don't believe you have to have your account linked through FB. Make sure adblock is off, click share when you have completed a magic lamp quest, then click claim at the bottom next to your reward items. Use your magic cloth on your lamp and watch what happens next.

    PS: Invite still doesn't seem to work.

  • #2
    I am guessing that INVITE doesn't work unless your friend plays the game.

    Comment


    • #3
      I invited a friend, they joined and nothing. Maybe someone else will have more luck with it.

      Comment


      • #4
        i have same problem

        Comment


        • #5
          ive got alot of friends playing the game, have invited loads but still the lamp just doesn't work for me or any of my friends, wont let me share anything ? i just don't get it :/

          Comment


          • #6
            if you're using google chrome turn off the add blocker but yeah the invite a friend doesn't work

            Comment


            • #7
              they cant get the invite to work they dont know if its on facebooks end or there end i asked this the other day and the mods answered that. i sent in a ticket and asked about it also 6 days agao and still no
              response on the ticket but the invite does not work atm

              Comment

              Working...
              X