Announcement

Collapse
1 of 2 < >

R2Client Issue Survey #2

To contribute to making the R2Client better, please click here to take a survey.
2 of 2 < >

Official Community Discord Server

Join us on the new R2Games Community Discord Server! https://discord.gg/VFMzFDqKq5
See more
See less

Mount Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • R288240137
    started a topic Mount Issue

    Mount Issue

    I am having trouble with my mount. When my special mount expired it will not let me put my horse back on. When I click on the glamour button it says its successful but it is not allowing me to ride my mount. I have tried several things to try and fix this issue myself without luck. Thanks. My ride button for my mount is not lighting up.
    Last edited by R288240137; 08-03-2014, 03:08 PM.

  • LarienElanessë
    replied
    Have the same Problem. My servername Autumn hollow, Character Larien

    Leave a comment:


  • R247549489
    replied
    Hi, I no longer sit on my mount though he shows me that I use it?

    S1 Etix

    Leave a comment:


  • R288240137
    replied
    Thanks for the help, I have my mount back.

    Leave a comment:


  • Dee-Lo
    replied
    go to your mount training interface then try to dismount and mount again

    Leave a comment:


  • R288240137
    replied
    Hi I have waited patiently for some help. My husband and I have both tried everything we can think of to fix this issue so I can get my mount back. I was putting cash into the game and so was he but we will be forced to quit if this cannot be fixed. Could you please address this issue for me. Again my character name is Rydia and I play on the Spiderhook Vale server. I cannot get my mount back after using the spider. I hit glamour and it says it's successful but my ride button is not lighting up. Please try and fix this for me.

    Leave a comment:


  • R288240137
    replied
    Please help to resolve this issue, I really would like to have my horse back please.

    Leave a comment:


  • Unyilwang
    replied
    go to your mount tab, below your hero portrait, press - ride/mount or soemthing like that
    this happen to me also when my spider mount expired

    Leave a comment:


  • R288240137
    replied
    my characters name is Rydia my server is spiderhook vale. thank you

    Leave a comment:


  • R288240137
    replied
    Originally posted by Kitwritten View Post
    we need your character and server name
    Rydia on Spiderhookvale server.

    Leave a comment:


  • Kitwritten
    replied
    we need your character and server name

    Leave a comment:

Working...
X