Announcement

Collapse
1 of 2 < >

Forum PMs and Mail

Due to an error in the current version of vBulletin, most are experiencing errors with the private messaging system. Please do not send moderators private messages for assistance at this time. If you have an issue that requires privacy, let us know in your new post or thread and we will work with you to find another option. Thanks - The Moderation Team.
2 of 2 < >

R2 LOGIN ISSUES

For recent R2 login issues, please log in through the website starting with "https": https://www.r2games.com. In addition, the bookmark of the saved URL may still contain the word "http", please change it to "https". If this does not work for you, please clear the cache and cookies to complete the most recent update, or try again with another browser. Thank you.
See more
See less

World boss

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • World boss

    Today the first world boss of the day (29-08-2019)
    On our server (server 630) the world boss event opened, but the world boss didn't spawn at the right time, then finally came the message it spawned, but it came 3 times.
    Even after the message we couldn't attack it, i went to try and relog, and cleared cache, but i couldn't log back in, when i finally got back in 5 min later, the people who stayed in said that they where already done, but they also had just a battle screen and got kicked out again.

    Please do something about it, and also some sort of compensation, i don't care about the gold, but with my daily activities it is hard enough for me to get the 250 devo for event now or the 300 devo. And missing this wb will cost me that.

  • #2
    Did you happen to take any screenshots?
    Received a random forum error? Refresh the page first, sometimes the error message is the error.

    Some inboxes are broken, including mine. Please don't send me private messages at this time.

    Rules of the Forum are found here.

    R2Games Ticket System for browser games: https://www.r2games.com/support

    Comment


    • #3
      No because at first i thought it was just delayed, then i thought maybe it is because of my cache, that is why i tried to relog, when i couldn't relog, i was more busy with trying to get back in.
      I wasn't the only one on my server with this problem though, multiple tried to relog and weren't able to get back in, getting black screen.

      Comment

      Working...
      X