Announcement

Collapse
1 of 2 < >

Flash EOL

Attention: Adobe has blocked flash content from playing beginning January 12th. Please update to new client version 1.1.2.
2 of 2 < >

Official Community Discord Server

Have questions or concerns you want to talk about? Join us on the new R2Games Community Discord Server! https://discord.gg/VFMzFDqKq5
See more
See less

Kabam needs a Mini-Client!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kabam needs a Mini-Client!

    We seriously need a mini-client and if this is the wrong place to post it, please mods, can you move it to the right place?

  • #2
    +1 for this
    IGN: princestewii
    Class: Archer
    Server: Kabam 86

    Comment


    • #3
      You have my support, mini client please
      JLC3112@Kabam, US East, S31
      Knight

      Comment


      • #4
        Yeah we do really need a mini client, you have my support too.

        Kallepe
        US east
        Server 31 merged with 29
        Mage

        Comment

        Working...
        X