Announcement

Collapse

Official Community Discord Server

Join us on the new R2Games Community Discord Server! https://discord.gg/VFMzFDqKq5
See more
See less

Hide players button!?!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hide players button!?!

    Ok u ruin lots of things here and ok i understand...its all to get money. But why the hell u bring up this hide function into the game? It doesnt makes anyone to pay up more? Its not enough all other things but this just tops it all! I`m a pvp player and i like to see who is my oponent, what he has and what he casts....now nothing! I see some blur and my hero taking dmg...thats it!?! This totaly ruins already ruined pvp in this game... As i know this thing was brought to reduce lag...well got news for ya - IT DOESNT! So why the hell we should suffer with this thing too?!

  • #2
    The hide button is generally not bad idea, but bad realization.

    And lag is caused mainly by the monitoring JavaScript scripts, as soon as R2 decided to monitor more smoothly, the lag will be reduced.
    Unfortunately the last patch added more lag to battle opening screens. And it tends to upload more analytical data to servers.
    As they reduce performance on game loading screen, they reduce it also in the game.
    I am waiting for someone smart in R2Games to order removal of 90% of those scripts as non-needed (seems it only adds work to some coders and it pains majority of players).

    Comment


    • #3
      That button causes more lag on my end. I keep unclicking it so I can see my opponent. Then it re-clicks itself. Then I unclick it and everything has to load again. Repeating this through arena fights is ridiculous. I have to refresh my browser like every 4 or 5 fights. Either make it work or get rid of it. I can decide for myself if its laggy and needs to be enabled. Stop enabling it by default. Just put it in the setting menu and let the players decide.

      Comment


      • #4
        Does anyone else have the issue that when you click the button to not hide your enemies, it will after a few attcks hide them again? This is really annoying and takes away some of the thrill of fighting other players.

        Comment


        • #5
          This checking and unchecking is one of the main reasons this function irritated me. Like PJ says its reasonable to have that option and before it was realy handy just in the places i needed it - Cloud city and world boss, but now in this state is just unbearable and annoying.

          Comment


          • #6
            Originally posted by R217953291 View Post
            Does anyone else have the issue that when you click the button to not hide your enemies, it will after a few attcks hide them again? This is really annoying and takes away some of the thrill of fighting other players.
            It was designed that way, to turn on if the frame rate dropped too low. And since the frame rate always drops too low anytime you get enough damage numbers on screen, it's always going to turn on. It was yet another stupid decision, although I can at least understand why they might have made that choice, as opposed to all the other mind-bogglingly stupid decisions.

            Comment


            • #7
              Originally posted by R217953291 View Post
              Does anyone else have the issue that when you click the button to not hide your enemies, it will after a few attcks hide them again? This is really annoying and takes away some of the thrill of fighting other players.
              If you do it - here is what you start:
              1) new CPU/RAM evaluation, that always ends like MrFancyPants described
              2) fresh Google Analytics evaluation (implicitly asks for jQuery.js) = more CPU cycles and RAM stolen, which in fact lead to point 1) to bad evaluation

              I tried to unhide in sylph arena, it starts to load all opponent's sylphs (s/he has the same like me, so I was curious), show them for 2 rounds then hide them again, even I have all the skill effects hidden.

              Tried again with blocked JavaScript, exactly same result, but faster

              Comment

              Working...
              X