Announcement

Collapse

Official Community Discord Server

Need help? Found a bug? For faster assistance, join our Discord: https://discord.gg/VFMzFDqKq5
See more
See less

cannot access wilds

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Tried, nothing.
    Check your quest log, there should be a quest to travel to autaric plains. You need to do that first, then the quest to upgrade town hall, etc.
    Rivx - 66 Mage (78k BR) / 38 Archer (21k BR) @ Kabam S32 |
    Games: Dota 2, SC II, Dark Souls, Skyrim, WoW, D3, PoE

    Comment


    • #32
      Originally posted by SuzyTakeda View Post
      this way is going to help slow levels below lvl 50 to avoid the experience from the quest that has to be done in order to get to wilds
      so i tried what you said. i plundered a city and came back to home city interface. now i cannot access wilds again from devotion quests as it is completed. so i guess i will have to stick with going to wilds from battle mail for now. but thank you for suggestion.
      let me cart. find someone else to help you suicide

      Comment

      Working...
      X