Announcement

Collapse
1 of 2 < >

Forum PMs and Mail

Due to an error in the current version of vBulletin, most are experiencing errors with the private messaging system. Please do not send moderators private messages for assistance at this time. If you have an issue that requires privacy, let us know in your new post or thread and we will work with you to find another option. Thanks - The Moderation Team.
2 of 2 < >

R2 LOGIN ISSUES

For recent R2 login issues, please log in through the website starting with "https": https://www.r2games.com. In addition, the bookmark of the saved URL may still contain the word "http", please change it to "https". If this does not work for you, please clear the cache and cookies to complete the most recent update, or try again with another browser. Thank you.
See more
See less

Problem with connection

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • nicolassaldamando2
    started a topic Problem with connection

    Problem with connection

    Hi, since yesterday that I'm trying to join into servers but they're not loading. (I play S8 but I tested all of them to see if the problem persist in each others). It's weird cause I can play LoA, Crystal Saga and Wartune with totally normality. I will waiting for some response, thanks a lot.
    PD: I have a decent internet connection, so I think that's not the problem.
    Last edited by nicolassaldamando2; 11-14-2019, 09:16 PM.

  • chicosuave777
    replied
    same issue server 8 but all servers not loading

    Leave a comment:


  • Iraklis Fakidis
    replied
    hello,since afternoon today i cannot enter to the game.It is loading but when i press start it is freezed whithout any further movement

    Leave a comment:


  • MemoryLane
    replied
    I'll pass this along to the team, see if there's a reason why the game doesn't work in the client.

    Leave a comment:


  • nicolassaldamando2
    replied
    Okay, that was the issue xD. Now I can play perfectly, thanks a lot. I owe you a favour.

    Leave a comment:


  • MemoryLane
    replied
    Have you tried using a browser?

    Leave a comment:


  • nicolassaldamando2
    replied
    This is what appears when I try to play. Nothing load but when I open, for example, Dragon Awaken everything works perfectly.

    Leave a comment:


  • nicolassaldamando2
    replied
    Yes, game it's in closed beta? Maybe that can explain the issue, I don't know.

    Leave a comment:


  • MemoryLane
    replied
    Are you still having this issue today?

    Leave a comment:

Working...
X