Announcement

Collapse
1 of 2 < >

Forum PMs and Mail

Due to an error in the current version of vBulletin, most are experiencing errors with the private messaging system. Please do not send moderators private messages for assistance at this time. If you have an issue that requires privacy, let us know in your new post or thread and we will work with you to find another option. Thanks - The Moderation Team.
2 of 2 < >

R2 LOGIN ISSUES

For recent R2 login issues, please log in through the website starting with "https": https://www.r2games.com. In addition, the bookmark of the saved URL may still contain the word "http", please change it to "https". If this does not work for you, please clear the cache and cookies to complete the most recent update, or try again with another browser. Thank you.
See more
See less

Recharge bug

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Recharge bug

    I tried 3x to purchase the $20 package. All 3 times xsolla said it couldn't complete the transaction. I called to check the balance on that credit card and there's more then enough money there, and xsolla charged my card all 3 times. So, I paid $60 and got not 1 diamond.

  • #2
    forgot to mention i tried to recharge on US East S278, IGN Discordia

    Comment


    • #3
      If xsolla said the transaction is not complete and still charged you then you need to contact xsolla support. If xsolla said the transaction was completed and you did not receive any diamonds then you should contact R2 billing found on the top right corner of your ingame status bar through support.

      Happy Chinese New Year!

      Comment

      Working...
      X