Official Community Discord Server

Need help? Found a bug? For faster assistance, join our Discord:
See more
See less

Khaos Atlas wont open to equip

  • Filter
  • Time
  • Show
Clear All
new posts

  • Khaos Atlas wont open to equip

    My Khaos Atlas will no open it just freezes. I've done every thing on my end and nothing has worked. Could you please help me with this issue. Writing a ticket is useless as they dont answer. IGN Funk server UA97

  • #2
    I'm having the same problem on the same server. IGN Sinner server UA97


    • #3
      Is there an error on the screen when attempting to open it? Is it showing that it's loading? Can you provide a screenshot, please?
      New R2 Community Discord Server:

      Received a random forum error? Refresh the page first, sometimes the error message is the error.

      Some inboxes are broken, including mine. Please don't send me private messages at this time.

      Rules of the Forum are found here.

      R2Games Ticket System for browser games:


      • #4
        HI, no there isn't any errors the server freezes attemping to load in equip and every thing just stops. The clocks dont count nothing works. I have sat there for 20 mins and it never recovered. I had to close the server and log back on just to get things working again. I have tried to put in a ticket on my main account 2 months ago for server lag and never received any response. UA97 has server lag as does probably every other sever. As a SS wont provide any help in this situation could you please forward this and have accounts Funk and Sinner looked at because they are alts and have the same issue.
        I wish a could provide you what you need but trust me it just freezes up and cant do anything no matter how long i wait.