Announcement

Collapse
1 of 2 < >

Flash EOL

Attention: Adobe has blocked flash content from playing beginning January 12th. Please update to new client version 1.1.2.
2 of 2 < >

Official Community Discord Server

Have questions or concerns you want to talk about? Join us on the new R2Games Community Discord Server! https://discord.gg/VFMzFDqKq5
See more
See less

want stable 4 !

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • want stable 4 !

    GM could you sell mount training whips pack with high discount ?
    i want upgrade my stable to level 4 !
    but so very expensive for normal price .




    S40-The Badlands
    Namira

  • #2
    i agree with that..101k is too much -__-

    Comment

    Working...
    X