Announcement

Collapse

R2 LOGIN ISSUES

For recent R2 login issues, please log in through the website starting with "https": https://www.r2games.com. In addition, the bookmark of the saved URL may still contain the word "http", please change it to "https". If this does not work for you, please clear the cache and cookies to complete the most recent update, or try again with another browser. Thank you.
See more
See less

cannot log in

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot log in

    anyone having issue logging in? can't log in for almost 12 hours now. s33 here.

  • #2
    I'm not certain why you're having connectivity issues. Have you tried any of the following?
    1. Clearing your browser history, cache, and cookies?
    2. Did you try another browser?
    3. Have you tried restarting your modem and/or computer?
    4. Checked to make sure your browser and drives are all up to date?
    5. Have you checked the stability of your connection and speed?
    6. Have you moved your router/modem recently?
    7. Are there too many people connected to your internet that's draining it?
    If you have a problem, need assistance and we can't help? Submit a ticket with R2 here
    Please, view the bug report list here - CS1
    Forum Rules are located here
    Please, view the bug report list here - CS2
    Looking for a guide? Try here.*

    CS1 - FAQ here

    Please, note my inbox is broken. Post your issue or question on the forums.

    Comment


    • #3
      i have done all those above. even changed OS but still nothing.

      note: can log in now. thanks

      Comment

      Working...
      X